Welcome, Guest Login

Support Center

Unable to start container: "VZVolumeMountExW failed"

Last Updated: Sep 08, 2016 11:37AM UTC

Symptoms

Container startup fails with the following error:

C:> vzctl start 101 
Starting container ... 
Parallels Virtuozzo Containers API function call "VZVolumeMountExW" failed (C:\VZ\Private\101\root.efd, {89B53077-4330-4E33-83E9-5F9968F2E13B}) err = 32 
Parallels Virtuozzo Containers API function call "dq_mount" failed 
Cannot set disk quota for container 101 
Cannot mount disk for container 101  

Note!: Error code 32 is important, it distinguishes this issue from any other ones. If you receive a different error code - ignore this article.

Cause

During a container operation, the root.efd file can become highly fragmented. NTFS does not release the file control block for highly fragmented files, which prevents the rood.efd file from being mounted.

Microsoft confirmed this issue as a bug, and addressed it in the scope of the LDR Update KB2707576.

Resolution

To mitigate the issue it's necessary to install update KB2707576, and reboot the hardware node.

If the node cannot be rebooted at the moment you can use attached vzefdunlocker.exe to unlock the container. Below you may find instructions for using the tool:

NOTE! ONLY USE THIS SOLUTION IF THE ERROR IS "err = 32"!

  1. Download and unpack the attached archive

  2. Open the command prompt and locate vzefdunlocker that was downloaded on the previous step

  3. Run following command:

    C:\>vzefdunlocker.exe <CTID>
    

    Note!: Replace <CTID> with the actual container ID

    Note!: Do not interrupt vzefdunlocker tool! Execution time depends on root.efd size, thus it might take a while to complete.

  4. Start the container once the tool completes its job

Real-life example:

C:\>vzefdunlocker.exe 1770 
Unlocking the container disk. It will take time depending on the size of the container disk.
The container disk was unlocked successfully.

C:\>vzctl start 1770
Starting container ...
Container is mounted
Container was started

Additional Information

For more help, see:

Article #2509299 VZ partition best practices

Article #2509300 Issues caused by high fragmentation of root.efd

Attachments

Open a new case
















  • You can call our Support Team:

     +1 855-466-6670  Toll-free
     +1 425-689-7142  US
     +44 203-389-8331  UK
     +49 8914-379-4365  DE
     +7 499-609-2754  RU
e13d0138f9baaceff06b8753a609e5c0@virtuozzo.desk-mail.com
https://cdn.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete